Ingreso rápido:  

Forum: German Forum

Tema: VDJ hängt sich auf
Moin Moin miteinander


Ich hab ein neuen Laptop und VDJ neu runtergeladen und hab das Problem das sich nach einiger Zeit sich einmal alles kurz aufhängen und somit die Lieder bzw das Lied was Grade läuft hackt, (ich weiß nicht wie ich es beschreiben soll es ist so wie als würde auf eine CD ein richtiger Sprung drin sein)
Es kommt nicht regelmäßig sondern immer Mal wider nach 10min nach 20min oder auch nach 5 min.
Habe schon VDJ einmal neu runtergeladen und den Laptop alle Energiesparmodus raus genommen bloß leider bringt es nicht.

Hat vielleicht von euch jemand eine Idee wo rann es liegen könnte ??

Mfg Patrick
 

Mensajes Sat 11 Jun 22 @ 7:25 pm
Hallo Patrick,
kannst Du etwas zu Deinem Laptop sagen?
Prozessor, RAM, Betriebssystem?

LG
Woelfl
 

Mensajes Sun 12 Jun 22 @ 6:10 am
AMD Ryzen 5 4000-Serie , 8GB DDR4 RAM / Full HD IPS 60 Hz , Nvidia GTX 1650

Wird für nichts anderes genutzt
 

Mensajes Tue 14 Jun 22 @ 2:58 pm
ich könnte mir bei den 8GB vorstellen, dass es mit den Stems zu tun hat. Deaktiviere diese mal bzw. die MathEngine.

Die Berechnung benötigt jede Menge Rechenkapazität
 

Mensajes Tue 14 Jun 22 @ 4:17 pm
Auf was steht es denn bei "MathEngine"?
CPU? Ändern auf ----> GPU
GPU? NVidia Treiber auf neuesten Stand?

Und:
Wo steht z. B. "useLowPowerGPU"?
Was bei "precomputeStems"?
Oder "skinFPS"?
"videoDriver" und "videoFPS" wären die nächsten Kandidaten?!

Was hängt denn zum bedienen dran (Controller)?
 

Mensajes Tue 14 Jun 22 @ 10:13 pm
Wo find ich die ganzen Möglichkeiten zum Umstellen bzw wo kann ich es nachschauen ??

Console ist ein MC6000MK2
Aber mit dem alten Laptop keine Problem gehabt
 

Mensajes Wed 15 Jun 22 @ 7:27 pm
 

Mensajes Mon 20 Jun 22 @ 10:39 pm
Hallo Patrick :-)

Ich hatte ein ähnliches Problem.
Ich habe mir vor ca. 3 Wochen ein neues Notebook (Lenovo Thinkpad T480s, mit I7, 24 GB RAM, 1 TB M.2 SSD, Touchscreen, usw. und Win 10 Pro [genutzt in Verbindung mit meinem Hauptcontroller Roland DJ 707M] ) gekauft. Das gleiche Problem mit den Musikaussetzern wie bei dir. Hinzu kam, dass nach ca. 5 Minuten, wenn ich Virtual DJ einfach nur einen Song abspielen ließ (also sozusagen im kurzzeitigen Standalone-Betrieb laufen ließ) beim Berühren des Touchpads die Musik ebenfalls stockte. Als 3. Problem kam hin und wieder eine unsaubere Wiedergabe der Songs vor.
Ich habe nun 3 Wochen "rumgebastelt" und das Web durchforstet.
Zur Info vorweg. Es lag nicht am Notebook sondern an Windows und der Software.
Seit kurzem läuft mein Notebook bzw. mein Virtual DJ einwandfrei.
Was habe ich gemacht?
Folgendes:

- Automatische Wartung von Windows (Hintergrundprozess, der bei Inaktivität automatisch startet) generell beenden.
- Microsoft Defender Antivirus deaktivieren (der Echtzeitschutz muss bei jedem Systemstart auf ein neues deaktiviert werden)
- Im Taskmanager unter "Details" (nach dem Start von Virtual DJ) mit Rechtsklick auf die dort angezeigte Programmdatei von Virtual DJ klicken und die Priorität von "Normal" auf "Hoch" umstellen. Das muss bei jedem Programmstart gemacht werden, weil sich nach dem Beenden des Programmes die Priorität auf den Standardwert zurücksetzt.
- Notebook im DJ-Betrieb in den Flugmodus versetzen.
- Sämtliche nicht fürs DJing benötigte Software vom Notebook deinstallieren.
- Windows-Update deaktivieren
- Die aktuellsten Treiber verwenden.
- Im BIOS (bei mir) das CPU Power Management auf "disabled" umstellen, damit die CPU kein Nickerchen macht.
- Die Windows Energiespareinstellungen überall wo es geht auf Maximale Leistung umstellen bzw. z.B. das Ausschalten des Bildschirms, der Festplatte, whatever auf niemals umstellen.
- In Virtual DJ in den Einstellungen im Audiobereich die Audiopuffergröße des ASIO-Treibers erhöhen (bei mir für den Roland-Controller - andere Controller ggf. andere Werte). Ich habe die Einstellung von 6 auf 9 geändert (=höhere Stabilität). Die Puffergröße wird damit von 256 auf 1024 Samples erhöht.
- In den Soundeinstellungen von Windows (Rechtsklick unten rechts auf das Lautsprechersymbol in der Taskleiste) bei Ausgabe und Eingabe die Notebook-interne Soundkarte einstellen und nicht die Controller-Soundkarte verwenden. Der Controller gibt den Sound eigenständig wieder. Eine gleichzeitige Verwendung der Controller-Soundkarte für den Windowssound kann zu Komplikationen führen. Zudem werden Systemtöne so über den Controller abgespielt. Wer will schon beim Gig Windowshinweistöne hören? ;-)
- In Virtual DJ die Priorität für das Laden der Songs in die Decks auf "low" umstellen. Und ggf., wie oben bereits erwähnt, die Stems ausstellen - oder die Priorität deren Berechnung reduzieren.
- Als letzte aber vermutlich wenig hilfreiche Aktion habe ich ein paar unwichtige Windows-Dienste beendet, damit sie nicht beim Hochfahren gestartet werden und im Hintergrund rumwerkeln. Eine Liste von unbedenklich abschaltbaren Diensten kann man easy im Web finden.

Mit diesen Einstellungen/Änderungen läufts bei mir nun einwandfrei. Habe es mit 4 Songs parallel, Effekten, Stems, Programm minimieren und andere Programme starten, getestet. Probleme mit der Musikwiedergabe sind seither nicht wieder aufgetreten. Hoffen wir mal, dass es so bleibt ;-)

Ich hoffe, dass ich dir und ggf. anderen mit ähnlichen Problemen mit diesem Post etwas helfen konnte.

Beste Grüße
Carsten
 

Mensajes Thu 23 Jun 22 @ 11:24 am